MODIFICATION de la sonde de temp

Montrez vos montages et adaptations
Ballu
note: 0/10
Messages : 24
Inscription : ven. 28 déc. 2018 15:50

Re: MODIFICATION de la sonde de temp

Message par Ballu » lun. 25 nov. 2019 22:49

Salut.
J'ai une idée qui me trotte dans la tête, qui va peut être paraitre totalement débile pour quelqu'un qui s'y connait et qui est totalement irréalisable pour moi !

Si on "fabriquait un circuit imprimé" qui utiliserait la sonde de température du véhicule plutôt qu'une CTN rajoutée ?
J'explique, à la place de la CTN que l'on rajoute, on se sert des 2 fils de la sonde d'origine ?
On mesure la résistance de la sonde d'origine à disons (au hasard à mon niveau, lol) 30°.
Notre circuit imprimé (ou un relais ???) fait en sorte que:
Si la temp de l'eau est supérieure à 30° (je parle de temp mais en réalité, il serait plus juste de parler de la valeur de la sonde de temp d'eau en Ohm), le circuit passe sur Nf c'est à dire sans modif = en position d'origine.
Si la temp de l'eau est inférieure à 30 °, alors le circuit passe sur No est donc se fait au travers d'une résistance de 10 KOhm, et dés que la temp atteint les 30°, on passe dans le cas 1 et le relais bascule sur Nf.

On pourrait peut être même améliorer le truc en le rendant encore plus progressif (je n'en sais toujours rien, lol) en prenant plusieurs mesures.
Il faudrait par exemple mesurait sa résistance de la sonde d'origine lorsque l'eau du circuit est de, par exemple, 30° et 60°.
Fort de ces mesures (que l'on peut changer et/ou multiplier), on branche la sonde d'origine sur notre circuit qui je pense doit nécessiter un petit processeur.
1) Alors, si la température mesurée par notre sonde d'origine est supérieure ou égale à 60°, alors, le circuit se fait normalement comme d'origine.
2) Si la température mesurée est comprise entre 30 et 60°, alors le circuit se fait en passant par une résistance supplémentaire de 5KOhm.
3) En dessous de 30 °, c'est via une résistance de 10 KOhm que le circuit se ferait.

Sauf erreur de ma part (et y'a de grandes chances que je me plante), l'avantage d'un tel système serait qu'il peut être branché en permanence (+ permanent facile à trouver dans le compartiment moteur), qu'il s'adapterait de lui même à des démarrages à froid, à chaud et entre les deux. Il y aurait simplement besoin d'un interrupteur pour couper le système et le laisser en position d'origine en cas de repassage à l'essence mais vu les faibles manipulations de ce dernier, il peut aussi rester dans le compartiment moteur.

Qu'en pensez vous ?

yatro
note: 1/10
Messages : 37
Inscription : dim. 17 févr. 2019 16:36

Re: MODIFICATION de la sonde de temp

Message par yatro » mar. 26 nov. 2019 06:33

L'idée est pas mal : utiliser la sonde de la voiture permet de limiter le nombre de composant.

J'y vois tout de même deux problèmes : d'une part il faut exploiter la sonde d'origine sans perturber la lecture par le calculateur. Et d'autre part, le moteur mettant du temps à chauffer (10min minimum pour atteindre une température stable du ldr), l'enrichissement restera actif plus longtemps que nécessaire.

Utiliser la sonde d'origine dépendra fortement du véhicule : par exemple certains ont des sondes à deux fils et d'autre en ont qu'un seul.

Partant de ce principe, on peut faire encore plus basique pour chercher la simplicité : on met en parallèle une résistance et un klixon 30°c le tout sur durite de ldr : si la température est inférieur à 30°c la résistance est activé, si >30°c la résistance st shuntée. Pour plus de progressivité, on peux mettre deux ou trois fois le principe klixon / R.

On se passe alors de comparateur de tension ou de microcontroleur.

Pour moi, quitte a sortir l'artillerie lourde (microcontroleur type arduino) on pourrait prendre plus de paramètres : température moteur, température carburant, minuterie, etc... et paramétrer plus de fonction :

Pas de starter si temp moteur >40
Pas de starter si temp carburant >25
Durée de starter =3min Si temp moteur <10°
Durée de starter =30s Si temp moteur >10°
Progressivité avec 3 résistances differentes shuntées via 3 relais
Etc...

Par contre, on est loin du module de minuterie qui revient à 4€.

yatro
note: 1/10
Messages : 37
Inscription : dim. 17 févr. 2019 16:36

Re: MODIFICATION de la sonde de temp

Message par yatro » mar. 26 nov. 2019 06:55

Côté matériel, voici ce que j'ai utilisé :

Carte relai temporisé 2,5€
https://h5.fr.aliexpress.com/item/32348 ... 2348366731
S1, S2, S4 servent à configurer le temps de commutation du relai.
Il faut retirer S5 pour qu'il n'y ai pas de lien entre le commun du relai et l'alimentation de la carte.
Il faut couper le fil de la sonde de empérature et y insérer le contact normalement fermé du relai. Idem pour la CTN :
CTN 10kOhm 3950 0.5€
https://h5.fr.aliexpress.com/item/32810 ... 2810710984

3€ hors frais de port le module "troublouse".

ps : avant tout branchement du relai sur la voiture, il faut au préalable faire des tests du module pour comprendre son fonctionnement avec un multimètre.

Ballu
note: 0/10
Messages : 24
Inscription : ven. 28 déc. 2018 15:50

Re: MODIFICATION de la sonde de temp

Message par Ballu » mar. 26 nov. 2019 12:21

Mouais, mouais, c'est bien compliqué pour un ptit bricolo comme moi !!!
Mon interrupteur fonctionne très bien, je crois que je vais rester ainsi et en plus, cela m'évite de prêter la caisse (c'est déjà pas si souvent qu'on me la demande) et quand je lui explique ça, il me regarde avec de gros yeux et finalement, il trouve un autre véhicule (peut être par peur qu'elle lui explose à la gue.le) !

yatro
note: 1/10
Messages : 37
Inscription : dim. 17 févr. 2019 16:36

Re: MODIFICATION de la sonde de temp

Message par yatro » mar. 26 nov. 2019 16:57

Honnêtement, si tu as déjà un interrupteur, le job est quasi terminé puisque la dernière chose à trouver est un +APC.

Pour l'idée d'asservir le starter à la température du ldr, je creuse la question. On pourrait utiliser un regulateur de température en mode refrigeration : au dessus d'une température réglée, le relai se ferme (au lieu d'alimenter une clim ou un ventilateur, on l'utiliserai pour shunter la résistance.)
Voir si cette carte peut faire le job :
https://m.fr.aliexpress.com/item/328705 ... 4787121850

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » sam. 11 avr. 2020 03:24

Bonjour Yatro,
J'ai acheté le module de Troublouse.
Mais malheureusement que crois que je l'ai mal branché.
Il est parfaitement mis sur la sonde de température. Mais là où j'ai un soucis c'est pour trouver le 12v APC...

Déjà pour éviter tous problème avec le circuit. J'ai fais passer un câble du moteur jusqu'au l'habitacle du véhicule. (dans le moteur je passe le câble derrière la boîte à air où il y a un petit trou ou passe déjà des cables qui vont a l'intérieur. Et ce petit trou débauche sur la gauche de la pédale d'embrayage).
Après avoir passé le câble par ici, je l'ai remonter dans le comportement ou on règle la hauteur des feu et éclairage du tableau de bord (comme ça j'ai juste besoin d'ouvrir la petite trappe sur le côté de la portière pour accéder au module.
Juste que la tout va bien.
J'ai trouvé un 12v APC qui fait allumé cigare et radio.
Quand je donne le premier tour de clé le module s'allume et la temp fonctionne. Mais quand je donne le second quart de tour de clé. Elle s'éteint pendant que le moteur démarre (1sec) puis le module redémarre avec la tempo aussi. Bon je pense que pendant la seconde ou le module est éteint, c'est le moment où le module doit être fonctionnel a 100%.
Avec mon OBD2 (torque) avant démarrage la température est de -7° au moment du démarrage 17° (température réel) et quand le véhicule a démarré elle repasse a -7 pendant 15sec.

Je voulais savoir où trouver un 12v APC qui ne se coupe pas au moment du démarrage.

Merci a vous
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

marianob
note: 3/10
Messages : 334
Inscription : mer. 7 mai 2008 07:04
Localisation : 77500

Re: MODIFICATION de la sonde de temp

Message par marianob » sam. 11 avr. 2020 07:08

Il me semble que quand je tourne la clé au démarrage la radio se coupe 1 seconde ou une fraction également, sans doute que le démarrage prend toute l'énergie, mais ça n'empêche pas mon module de fonctionner. Mon +APC je l'ai récupéré dans la boîte à fusibles du compartiment moteur.
Par mon expérience avec un potard sur mon Picasso la valeur de la température reste en mémoire un petit temps, si j'oubliais de mettre le potard au premier démarrage il me fallait mettre et enlever le contact 5 ou 6 fois afin que la température s'ajuste.
Du coup je suis étonné qu'en 1 fraction de seconde la température augmente avec ton module.
Pour essayer je remplacerai ou rajouterai sur le départ de la sonde une résistance supplémentaire afin que la température lue ne soit pas de -7 mais bien plus basse, c'est peut-être tout simplement la valeur de la sonde qui est trop faible pour démarrer.
C5 Tourer 1.8 depuis 2010 à 100% d'E85 avec module auto pour démarrage, Picasso 1.8 de 2008 à 2017, 100% d'E85 avec potard pour démarrage. MP3 400 à 70% d'E85. Jadis j'ai eu une XM 2.0i à 90%

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » sam. 11 avr. 2020 14:07

Il est possible de me montrer comment tu as fait pour récupérer le +12V ACP dans la boîte a fusible. Je suis curieux.. je te mets ma boîte a fusible en lien

J'ai une clio GT 128cv avec une petite reprog E85 (140cv)
Moteur K4M (le même que la Twingo 2 RS et Wind)

https://drive.google.com/folderview?id= ... yBsImQrsnc
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

marianob
note: 3/10
Messages : 334
Inscription : mer. 7 mai 2008 07:04
Localisation : 77500

Re: MODIFICATION de la sonde de temp

Message par marianob » sam. 11 avr. 2020 15:20

Je ne suis ni doué ni savant, j'ai juste
- ouvert la boîte à fusibles du compartiment et mis une cosse du multimètre à la masse
- testé avec le multimètre en mode voltmètre la tension contact sur off depuis le dessus du fusible,
- Quand j'en avais un qui n'avait pas de tension, retester avec le contact mis et si j'avais de la tension c'est un +APC.
- Pour bien faire, enlever le fusible et tester de quel côté arrive le 12V, se connecter sur l'autre afin d'être protégé par le fusible, de toute manière j'ai un autre fusible dans a boîte plexo du module.
Mais je ne pense pas que ton problème vienne du +APC
C5 Tourer 1.8 depuis 2010 à 100% d'E85 avec module auto pour démarrage, Picasso 1.8 de 2008 à 2017, 100% d'E85 avec potard pour démarrage. MP3 400 à 70% d'E85. Jadis j'ai eu une XM 2.0i à 90%

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » sam. 11 avr. 2020 16:16

Merci beaucoup pour toutes tes explications. J'ai tout compris sauf le dernier point. Comment on fait pour connecter le fil de +12v au fusible ? 🙄

En plus comme vous pouvez voir dans ma galerie photo https://drive.google.com/folderview?id= ... yBsImQrsnc

Sur mon véhicule il manque une rangé de fusible et de connecteur. Et parmi les fusibles manquant il y'a celui des injecteurs et gestion moteur.

Ou puis-je trouver ses fusibles?
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

marianob
note: 3/10
Messages : 334
Inscription : mer. 7 mai 2008 07:04
Localisation : 77500

Re: MODIFICATION de la sonde de temp

Message par marianob » dim. 12 avr. 2020 07:18

J'ai 5 fois plus de fusibles sur ma c5, pour repiquer un câble sur un fusible, tu le dénudes et le mets dans le porte fusibles en mettant le fusible ça le bloquera.

En vérifiant mes photos je n'avais pas fait comme cela, j'avais trouvé un +APC qui sortait de la boite à fusibles, voir câble marron pris sur le câble jaune sur la photo, connecteur en bas à droite.

Mais essaie plutôt d'augmenter la résistance de ta thermistance.

Image
C5 Tourer 1.8 depuis 2010 à 100% d'E85 avec module auto pour démarrage, Picasso 1.8 de 2008 à 2017, 100% d'E85 avec potard pour démarrage. MP3 400 à 70% d'E85. Jadis j'ai eu une XM 2.0i à 90%

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » lun. 13 avr. 2020 16:23

Super ! Je viens de le faire sur le fusible des injecteurs façon parfaite au premier coup de clé ! Il n'y a plus la micro coupure qu'on peut trouver sur le 12v APC de l'autoradio ou allumé cigare.

Par contre j'ai démonté mes bobines que j'ai monté en décembre 2018. En mai 2019 une était plein de rouille. Et la elle est encore pleine de rouille malgré le nettoyage. De plus il y'a un peu d'huile au fond du puit (tout à gauche) les autres RAS. vous savez de quoi cela peut venir ?

Voir photo https://drive.google.com/file/d/1-1Zd2E ... p=drivesdk


Modif: j'ai trouvé 2 jours après pourquoi le puit, bobine + bougies étaient rouillé...

Quelque chose de très con.. la durite de 20cm qui amène le liquide lave glace de la buse droite du véhicule était rendu au niveau du coude avant de se clipser dans la buse.

Vu que la durite était fendu il y avait quelques petites goûtes petit à petit qui tombait pile sur la bobine de gauche...

Vérifiez bien cette durite, c'est une maladie chez les modus Mégane kangoo et clio.
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » lun. 20 avr. 2020 21:38

Bon j'ai commandé des injecteurs avec un débit supérieur pour ma clio 3 GT qui roule a l'éthanol.

https://www.meat-doria.com/en/product_meat/75112242
Et au moment de remettre la rampe des injecteurs c'est le drame ! La rampe est trop courte. Les injecteurs ne vont pas parfaitement au fond :(
Après quelques recherches sur internet. Il s'agit des injecteurs spécial pour la clio 3 GT, Twingo 2 RS et Wind.

Ci-joint la photo.
https://drive.google.com/folderview?id= ... hkJRRiCyGT

Je voulais savoir si c'était possible d'avoir des injecteurs comme les miens avec un débit plus important ?

Mer xi
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

yatro
note: 1/10
Messages : 37
Inscription : dim. 17 févr. 2019 16:36

Re: MODIFICATION de la sonde de temp

Message par yatro » mar. 21 avr. 2020 19:21

Bonjour.

On est plus trop dans la modification de sonde de température ;-)

Je suis pas du tout un spécialiste des injecteurs mais sauf erreur les iwp042 devraient se monter. Ils se montent sur beaucoup de f4r (2.0 renault) et ce sont ceux que j'ai monté sur un k4m de laguna 1.

Au vu des photos que tu as mis, je ne vois pas de grosse différence entre les tiens et les iwp042.
Tu as pu mesurer des différences avec un pied à coulisse ?
Graisser un peu les joints te permettrait de rentrer les injecteurs plus facilement ?

Ps : lors de la reprog le préparateur à dû toucher les temps d'injection de ta cartographie. Ne crains tu pas que augmentation des temps + gros injecteur = beaucoup trop riche ? Si c'est le cas tu auras rapidement un ltft très négatif.

valz45
note: 0/10
Messages : 6
Inscription : sam. 11 avr. 2020 03:11

Re: MODIFICATION de la sonde de temp

Message par valz45 » mar. 21 avr. 2020 19:35

Les ipw042 sont trop court. Ils font de joint a joint 31mm et ceux d'origine 38mm.

J'ai fais un screenshots quand j'ai mis mon OBD2.

L'ajustement long terme était a 25% (fixe) comme avec les anciens.
Et l'ajustement a court terme a -75% (variable entre -70 et -80%).

Pour avoir ses résultats j'ai fais tourné mon véhicule pendant 20min a 800 tours.
Renault Clio 3 GT 128ch 1.6v K4M
Reprog 140ch avec une gestion E85
Bobines Valeo x4
Bougies iridium Denso

Répondre